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About the User Manual

This user manual includes guidance for some of the day-to-day tasks that
may be required by an administrator (computer lab in-charge, teacher).
It is assumed that the administration has some basic knowledge of
working with a Linux distribution as the server is intended to be used
to teach the Linux subject in schools. Providing comprehensive server
administration guidance is outside the scope of this document.

We have created My sCool Server keeping in mind the “ease of use” so
quite a lot of tasks(not all of them) can be accomplished without having
to RTFM [https://en.wikipedia.org/wiki/RTFM], however understanding that this device packs a lot of complex
technologies so to accomplish anything “under the hood” the
administrator must go through the instructions below at the minimum and
follow up reading the manuals provided by applications or online for
more details or tasks not covered here.


Important Notice

Recherche Tech has supplied this information believing it to be accurate
and reliable at the time of publishing, but is presented without
warranty of any kind, expressed or implied. Users must take full
responsibility for their application of any products. Recherche assumes
no responsibility for any errors that may appear in this document.
Recherche reserves the right, without notice to make changes in product
design or specifications. Information is subject to change without
notice.




Restricted Rights

Copyright 2016-2018 Recherche Tech LLP. All rights reserved.

My sCool Server, My sCool Server logo are registered trademarks of Recherche Tech
LLP.




Contact


[image: ]



Corporate Headquarters


Recherche Tech LLP

501/B, Synergy Building, L-74, Corporate Road, Makarba, Ahmedabad,

Gujarat 380015. INDIA.

Phone: +91-79-40080440

Web site: http://www.myscoolserver.com

Visit http://www.myscoolserver.com/contact
for the regional and latest contact information.






Social


	Twitter

	https://www.twitter.com/myscoolserver



	Facebook

	https://www.facebook.com/myscoolserver



	Google+

	https://plus.google.com/+Myscoolserver













          

      

      

    

  

    
      
          
            
  
User Management


Create new user

Boot into Admin-Desktop, login as mssadmin and perform these steps –

Via GUI


	Navigate to System → Administration → Users and Groups


	Add new user by pressing the +Add button and fill in the details (You may have to wait for the existing user list to load.)


	Set the new user’s password in the next dialog




Via Terminal

sudo useradd -m <username>





Enter mssadmin’s password when prompted and continue.

Set the password to activate the user’s account.

sudo passwd <username>






Add user to epoptes group


Note

This must only be done for teacher accounts as it grants some extra priviledges.



Boot into Admin-Desktop, login as mssadmin and execute the following in a Terminal –

sudo usermod -a -G epoptes <username>





Enter mssadmin’s password when prompted and continue.






Change password


To change your own password

Via GUI

Alt+F2 -> ltsp-remoteapps users-admin





Press Change... against the Password: label. Thereafter set your password in the Change User Password dialog.

Via Terminal

Alt+F2 -> ltsp-remoteapps xterm -> passwd








To change password of other user

Boot into Admin-Desktop, login as mssadmin and perform these steps -

Via GUI


	Navigate to System → Administration → Users and Groups


	Select the user whose password needs changing


	Press Change... against the Password label


	Authenticate with mssadmin’s password when prompted


	Set new password in the Change User Password dialog




Via Terminal

sudo passwd <username>





Enter mssadmin’s password when prompted and continue.






Mass user addition

For adding  several users at one go, boot into Admin-Desktop, login as mssadmin* and perform these steps -


	Create space separated file containing “username password” such as this sample.


Steps:


	Use LibreOffice Calc to create the file


	Choose File -> Save as. You will see the Save as dialog.


	In the File type field select the format Text CSV (.csv).


	Enter a file name as users.csv and click Save.


	From the Export of text files dialog that appears, select the field delimeter as {space} for the data to be exported, and press OK.












Note

There should be no empty lines in the file.




	Open terminal and execute the command –




sudo massuseradd <path_to_csv_file>





Example:

sudo massuseradd /home/mssadmin/users.csv








Default credentials

By default, the appliance is shipped with the following user accounts pre-configured i.e. if no customisation has been requested during order placement –








	Account Type

	Username

	Password





	Admin

	mssadmin

	myskool



	Student

	student<n>

	12345



	Teacher

	teacher<n>

	imteacher







Warning

It is strongly recommend that a user must change the account password upon first time use.









          

      

      

    

  

    
      
          
            
  
Network Configuration


Via Network Manager

MSS comes with 2 predefined network configurations: Static and Dynamic.

If your network already has a DHCP server serving IP address to devices connected on your LAN then you need to configure the MSS in Dynamic mode. If no such DHCP server exists, then configure the MSS in Static mode.

It is safe to assume that in majority of cases where a new network has just been setup for the purpose of installing the MSS, there is no pre-existing DHCP server, hence one may safely opt for Static mode.

Herein are the details of how to configure in Static or Dynamic mode:

After login, edit the connection that would not be used and uncheck “Automatically connect to this network when it is available” to disable auto-connection attempts in the undesired mode. For example, herein below, we are disabling ‘Dynamic’ and enabling ‘Static’ mode.


[image: Network Manager - Edit Connections]


Network Manager - Edit Connections


[image: Network Connections Window]


Network Connections


[image: Editing dynamic window]


Uncheck to switch off dynamic mode


[image: Editing static window]


Check to switch on static mode

Finally, choose “static” in the Network Manager menu and your MSS is now operating in static mode.







          

      

      

    

  

    
      
          
            
  
Monitoring and Broadcasting


Epoptes

Epoptes is a monitoring and broadcasting tool to assist teachers in imparting lessons.

Only a user belonging to “epoptes” group can launch epoptes application, see Add user to epoptes group.

All pre-configured teacher accounts are already members of the epoptes group. Using epoptes is self evident and intuitive, however complete documentation is available here [https://translate.google.com/translate?u=http://ts.sch.gr/wiki/Linux/epoptes].

When using English-Desktop, a teacher can start Epoptes as below:

Alt+F2 -> ltsp-remoteapps epoptes






Create Epoptes Launcher

Using the steps herein a teacher may create a desktop launcher to start Epoptes with just a click.


	Right click on desktop and select Create launcher...


	In Create Launcher dialog do following steps -


	Enter Name as Epoptes


	Enter Command as ltsp-remoteapps epoptes


	Press OK









[image: Monitoring and Broadcasting - Epoptes Launcher]



Note

You may need to refresh (F5) the desktop to see the newly created launcher











          

      

      

    

  

    
      
          
            
  
Content Platform


Web Server

The My sCool Server comes pre-configured with a ready to use web server
to help you host your content and make it available on the local
network.

Pre-hosted content can be accessed from all clients powered by the MSS via any web browser at -

http://server/






Hosting custom conent

Boot into Admin-Desktop, login as mssadmin and put your custom content to be locally hosted at –

/var/www/html/mss/custom





The instructions for customisation of the custom content tile are available via a browser at -

http://server/mss/custom






Note

Do ensure that all content to be hosted should have the the following minimum permissions - read and execute for folders and read for files for the target audience.



Setting requisite permissions via Terminal

Execute the following commands in a terminal to set requisite permissions -

sudo find /var/www/html/mss/custom -type d -exec chmod a+rx {} \;
sudo find /var/www/html/mss/custom -type f -exec chmod a+r {} \;








Individual content hosting

There could be a need for each user to host their own HTML based web content. Each user can host one’s individual content at -

/home/<username>/public_html





and it may then be accessed by all connected clients at

http://server/~<username>






Note

Do ensure that all content to be hosted should have the the following minimum permissions - read and execute for folders and read for files for the target audience.











          

      

      

    

  

    
      
          
            
  
Take Linux Home


Create Live USB

Li-f-e: Linux for Education OS image is included on the server and can
be used to create a bootable media by booting into Admin-Desktop and thereafter logging in as mssadmin user.


	Note

	Select “isohybrid” / “EFI” option when creating a bootable media intended to
boot computers that only support EFI booting. This option can also boot
on legacy hardware so use this if you are not sure about your hardware
capabilities.

Use of “isohybrid” option is officially recommended way of
creating bootable USB, hence more reliable. Do note that this will wipe the
USB device and cannot be used as a normal storage media from Windows PC.

Use “Ubuntu” / “Legacy” option if you wish to use the device as a storage
media on Windows or to preserve data. This method requires one vfat formatted
partition on the USB stick. The partition should not be in use at the time of
creating boot media.
If booting fails using this method, use isohybrid / EFI mode.






Via Shortcuts

Use either of these launcher icons on the Desktop - Live USB GUI EFI or Live USB GUI Legacy as per your bootable media preference.




Via Menu

System Tools -> Live USB GUI





You will be requested for the ISO image in the above process. The Li-f-e.iso file is located at one of these directory paths - /recovery/ or /home/mssadmin/.




Via Terminal

It may be more convenient to use command line for running this task multiple
times.

sudo live-grub-stick --isohybrid /recovery/Li-f-e.iso /dev/sdb








References

See the following external links (requires internet) to learn how to boot from USB stick and
troubleshoot if the USB does not boot:

Change the boot order in BIOS [https://www.lifewire.com/change-the-boot-order-in-bios-2624528]

Boot from a USB device [https://www.lifewire.com/how-to-boot-from-a-usb-device-2626091]









          

      

      

    

  

    
      
          
            
  
Backup and Recovery

We understand that accidents happen and that everyone deserves a second chance. Being open-source one may be tempted to play around with the server and we do not penalise you for doing so. The My sCool Server provides Factory Restore options via –


	Server boot menu or


	USB created with the recovery.sh tool




Factory Restore option restores the system to the state the server left Recherche’s premises, which may include customisation such as user accounts etc., if the data is given at the time of order placement.


Warning

Exercise caution before using the Factory Restore feature. It shall override any customisations done by the user to the server and shall restore it to the factory shipping state. It may also delete user created data. Hence, if user generated data is of value, it is strongly recommended that /home data is periodically backed up on an external media by following the steps below.




Note

The Factory Restore feature does not restore any preloaded or custom loaded web-content. Backup and restoration of all content accessible via http://server is the responsibility of the end-user. Read below for easy and useful backup steps.



Multiple snapshots can be created. It is limited by space available on the /recovery partition. MSS uses borg deduplicated backup so only the changes made to system since the last backup are stored on subsequent backup attempts.


	To create a backup, run the following command as root (sudo su -):




recovery.sh create






	To restore to factory image from a running system, run the following as root (sudo su -):




recovery.sh restore [optional snapshot number]






	Snapshots are numerical, 1 denoting the factory image. By default, running restore will restore to that snapshot. To restore to last snapshot taken run the following as root (sudo su -):




recovery.sh restore last





Snapshot management is beyond the scope of this tool and document. Refer borg documentation [http://borgbackup.readthedocs.io/en/stable/usage.htm] for details.

Herein are just a few examples of what can be done with borg:


	To list all snapshots:




sudo borg list /recovery/system






	To create a custom snapshot, for example, creating a snapshot of /home:




borg init --encryption=none </backup/folder/path/home>

borg create --stats --progress --compression lz4 </backup/folder/path/home>::<snapshotname> /home






Note

/backup/folder/path/ must have sufficient space.




	To restore /home from snapshot:




borg mount </backup/folder/path/home>::<snapshotname> /mnt

rsync -avP /mnt/* /home/





When restoration is complete:

umount /mnt






Pre-loaded Content Locations

Most of the preloaded web content resides at the common location - /var/www/html/mss. However some of the content that have their own custom location are listed below -


	NROER

	/home/docker



	Gyankunj Slate

	/home/mssadmin/slate



	ePathshala

	/home/mssadmin/.epathshala











          

      

      

    

  

    
      
          
            
  
Troubleshooting


Booting or Freezing Problem

If the client machines do not boot or they freeze while working, it can be caused by a faulty network cable, connection or switch. Try connecting a client directly to the server using a LAN cable and attempt booting the client. If the client boots, it confirms that the client and server both are in working order. Then continue troubleshooting your physical network or contact your network engineer.

In case the client machines still do not boot after trying all above steps, contact the MSS support team.




Top Panel Missing

If the top panel does not show up execute the following –

Alt+F2 -> resetpanel








Restore Desktop to Default Settings

To restore the desktop to default settings of any user run this in terminal from mssadmin account login once the user has logged out –

sudo mv /home/<username>/.config /home/<username>/.config-backup





Next ask the user to login again.

or

Users can also try this from a running session -

Alt+F2 -> resetdesktop





User will need to log out and back in for changes to apply.




Remote Desktop Connection Issues

Try the following steps as mssadmin user (enter password when prompted) -

Check the status of the service

sudo systemctl status xrdp





Restart the service

sudo systemctl restart xrdp





To check the XRDP processes running

ps ax | grep xrdp





Log files related to XRDP

sudo tail -f /var/log/xrdp-sesman.log





To specifically diagnose rdp login issue.

sudo tail -f /var/log/auth.log





Try a user part from one that may currently be logged into an active session.







          

      

      

    

  

    
      
          
            
  
Remote Support

For getting support remotely from support team, perform the following steps -


	Login with any account, navigate to Applications → Internet →  Remmina


	Do following steps -






	RDP must be selected in dropdown box.


	Type server as shown below.


	Hit Connect !.





[image: Remote Support - Reminna]






	When connection is established, Login as mssadmin in remmina screen .






Note

Following steps should be perform in opened remmina window







	Connect Wi-Fi/Hotspot for Internet Connection, see Connect Wi-Fi/Hotspot section for getting connected to Internet via Wi-Fi/Hotspot.


	Launch Epoptes from Applications → Internet →  Epoptes


	Select Remote support option from Help → Remote support






[image: Remote Support - Epoptes]






	In remote-assistance dialog follow the steps below -






	In Method check if Graphic(VNC) is selected.


	In Host type support.myscoolserver.com:5500


	Hit Connect.





[image: Remote Support - Remote Assistance]






	On successful connection, Status will change to Connected.





Connect Wi-Fi/Hotspot

For connecting Wi-Fi/Hotspot in MSS, login as mssadmin and perform these steps -


	Click on [image: internet]  from top-right corner of the screen, and click the name of the network you want to connect to.






[image: Connect Wi-fi - Wi-fi List]



Note

If the name of the network is not in the list, select More networks to see if the network is further down the list. If you still do not see the network, your device may be out of range or the network might be hidden.







	Type password of mssadmin in Authenticate dialog as shown below and hit Authenticate.






[image: Connect Wi-fi - System Authentication]






	It will again prompt for the password with the Authenticate dialog, type password of mssadmin and hit Authenticate






[image: Connect Wi-fi - System Authentication]






	If the network is protected by a password, enter the password in Wi-Fi Network Authentication Required dialog when prompted and click Connect.






[image: Connect Wi-fi - Wi-fi Authentication]






	The network icon will change to [image: wifi]






Note

If the connection is not successful, you may be asked for your password again or it might just tell you that the connection has been disconnected.












          

      

      

    

  

    
      
          
            
  
Support and Guidance


Frequently asked questions

Answers to most frequent queries by the MSS users, collated from various perspectives, can be found herein -

http://myscoolserver.com/faqs




How-to Videos and Guides

The YouTube channel is regurlarly updated with basic usage training and new feature walk-through tutorials. Checkout the playlists section for your area of interest -

https://www.youtube.com/myscoolserver




Warranty support channels

Every My sCool Server has a sticker bearing a unique MSS ID or S/N (Serial Number). This ID is
important for all communications with Recherche Tech in regards to your
MSS hardware. If you ever have an issue with your MSS hardware and it is
under warranty, simply open a ticket through any of the support channels
and quote this MSS ID and the nature of your problem.

Support portal: https://helpdesk.myscoolserver.com

Email-id: helpdesk@myscoolserver.com

WhatsApp number: +91-79-40080440




Important Links

Terms of service and support [https://www.myscoolserver.com/mss-service-terms/]

Limited Warranty Terms [https://www.myscoolserver.com/recherche-limited-product-warranty-mss/]






Community Support


Learning resources

The My sCool Server comes preloaded with Hackett and Bankwell comic books 1
and content from Spoken Tutorial 2 that walks you through everything you need to know
about using Ubuntu linux, almost every GUI application comes with F1
help, and respective documentation in /usr/share/doc folder.

Community created documentation available at:


https://ubuntu-manual.org

https://help.ubuntu.com

https://ubuntu-mate.github.io

https://help.ubuntu.com/community/CommonQuestions

https://help.ubuntu.com/community/Beginners/FAQ

http://askubuntu.com/questions?sort=faq

https://ubuntu-mate.community/t/ubuntu-beginners-guide-complete-how-to-install-and-run-first-update/955/7

https://ubuntu-mate.org/faq






Ubuntu community help


http://community.ubuntu.com/help-information

https://ubuntu-mate.org/community






MSS community help

https://github.com/RechercheTech/mss/issues




Typing in your language

https://help.ubuntu.com/community/ibus




Li-f-e - Linux for Education help

https://sourceforge.net/projects/cyberorg-home/support




Must read before seeking community help

http://www.catb.org/esr/faqs/smart-questions.html


	1

	http://hackettandbankwell.com



	2

	http://spoken-tutorial.org/about-us













          

      

      

    

  

    
      
          
            
  
Contact Information
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Corporate Headquarters


Recherche Tech LLP

501/B, Synergy Building, L-74, Corporate Road, Makarba, Ahmedabad,

Gujarat 380015. INDIA.

Phone: +91-79-40080440

Web site: http://www.myscoolserver.com

Visit http://www.myscoolserver.com/contact
for the regional and latest contact information.






Social


	Twitter

	https://www.twitter.com/myscoolserver



	Facebook

	https://www.facebook.com/myscoolserver



	Google+

	https://plus.google.com/+Myscoolserver
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